aboutsummaryrefslogtreecommitdiffstats
path: root/compat/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'compat/src/meson.build')
-rw-r--r--compat/src/meson.build50
1 files changed, 50 insertions, 0 deletions
diff --git a/compat/src/meson.build b/compat/src/meson.build
new file mode 100644
index 0000000..b1df225
--- /dev/null
+++ b/compat/src/meson.build
@@ -0,0 +1,50 @@
+###########################################################################
+# Copyright (C) 2018 "IoT.bzh"
+#
+# author: José Bollo <jose.bollo@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+cyninc = include_directories('../../src', '../include')
+
+###########################################
+# build and install libcynara-compat
+###########################################
+if get_option('direct-cynara-compat')
+ cynalib = shared_library('cynara-compat', 'lib-compat.c', clisrcs,
+ version: cynara_version, soversion: cynara_soversion,
+ c_args: '-DDEFAULT_SOCKET_DIR="' + socketdir + '"',
+ include_directories: cyninc,
+ link_args: '-Wl,--version-script='+meson.current_source_dir()+'/export-cynara-compat.map',
+ install: true
+ )
+else
+ cynalib = shared_library('cynara-compat', 'lib-compat.c',
+ version: cynara_version, soversion: cynara_soversion,
+ c_args: '-DDEFAULT_SOCKET_DIR="' + socketdir + '"',
+ include_directories: cyninc,
+ link_args: '-Wl,--version-script='+meson.current_source_dir()+'/export-cynara-compat.map',
+ link_with: clilib,
+ install: true
+ )
+endif
+
+###########################################
+# build and install test-old-cynara
+###########################################
+executable('test-old-cynara', 'main-test-old-cynara.c',
+ install: true,
+ include_directories: cyninc,
+ link_with: cynalib
+)