summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2022-06-05 23:40:12 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2022-06-08 07:20:41 +0900
commitf20fa3f4f0a2698db38d993e3d0b86be58c41ef2 (patch)
tree5a0f76468cd96fe5f4112e213d81c376db95a7f8 /meson.build
parent53f4fe700dee88cc9840a91f2f297aacf05e08d4 (diff)
The drm-lease-manager create unix domain socket file to provide lease to lease client. In typical case, this file must be create before client boot up. But existing drm-lease-manager couldn't keep that sequence because that support startup ordering only using systemd service dependency. This patch add systemd notify support to realize more strictly ordaining. Bug-AGL: SPEC-4427 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: Icaad6c9df0696a48b9534c7586be7949a874f9a5
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 12 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index c2c88a6..1694a0a 100644
--- a/meson.build
+++ b/meson.build
@@ -28,15 +28,17 @@ add_project_arguments(
language: 'c'
)
-configure_file(output: 'config.h',
- configuration: config)
-
-configuration_inc = include_directories('.')
-
drm_dep = dependency('libdrm', version: '>= 2.4.89')
thread_dep = dependency('threads')
toml_dep = dependency('libtoml')
+systemd_dep = dependency('', required: false)
+if get_option('enable-systemd')
+ systemd_dep = dependency('libsystemd', required: false)
+
+ config.set('HAVE_SYSTEMD_DAEMON', '1')
+endif
+
enable_tests = get_option('enable-tests')
if enable_tests
@@ -56,6 +58,11 @@ if enable_tests
endif
endif
+configure_file(output: 'config.h',
+ configuration: config)
+
+configuration_inc = include_directories('.')
+
subdir('common')
subdir('libdlmclient')
subdir('drm-lease-manager')