summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDamian Hobson-Garcia <dhobsong@igel.co.jp>2021-03-19 16:04:35 +0900
committerDamian Hobson-Garcia <dhobsong@igel.co.jp>2021-04-06 10:33:11 +0900
commitd196375b8b130e119285fb19984870edc6941a90 (patch)
treec06a019549f4809458b3c8febd07660e1e6476a8 /meson.build
parentbdf7c337439ff0b70b67462c1f00f5b61942e76a (diff)
Free old lease fd reference after transition
After a lease is tranisitined to a new client, the reference to the previous client's lease fd is no longer needed and should be released. Close the old fd after the new client has either updated the display or its lease is revoked. Bug-AGL: SPEC-3816 Change-Id: I9612913e2960dce94bcfc6a35c0105a5670a453d Signed-off-by: Damian Hobson-Garcia <dhobsong@igel.co.jp>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2f6cd15..7f8adf5 100644
--- a/meson.build
+++ b/meson.build
@@ -34,12 +34,12 @@ configure_file(output: 'config.h',
configuration_inc = include_directories('.')
drm_dep = dependency('libdrm', version: '>= 2.4.89')
+thread_dep = dependency('threads')
enable_tests = get_option('enable-tests')
if enable_tests
check_dep = dependency('check')
- thread_dep = dependency('threads')
# Default to the system provided version of fff.h.
# otherwise fetch it ourselves.