aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 12 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index c2c88a6..1694a0a 100644
--- a/meson.build
+++ b/meson.build
@@ -28,15 +28,17 @@ add_project_arguments(
language: 'c'
)
-configure_file(output: 'config.h',
- configuration: config)
-
-configuration_inc = include_directories('.')
-
drm_dep = dependency('libdrm', version: '>= 2.4.89')
thread_dep = dependency('threads')
toml_dep = dependency('libtoml')
+systemd_dep = dependency('', required: false)
+if get_option('enable-systemd')
+ systemd_dep = dependency('libsystemd', required: false)
+
+ config.set('HAVE_SYSTEMD_DAEMON', '1')
+endif
+
enable_tests = get_option('enable-tests')
if enable_tests
@@ -56,6 +58,11 @@ if enable_tests
endif
endif
+configure_file(output: 'config.h',
+ configuration: config)
+
+configuration_inc = include_directories('.')
+
subdir('common')
subdir('libdlmclient')
subdir('drm-lease-manager')