aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2019-01-23 10:19:26 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2019-01-23 10:20:46 +0100
commit9bcc943e620004b3bafe043b452eb5ba4c7954c9 (patch)
tree632109a7f971a4f6e50b23e3c9464b9d7a8219eb /CMakeLists.txt
parentb7e6dbef56913fa43ea23b842ebe2933d9e0477e (diff)
Set PROJECT_VERSION overwritable by cli
Use AGLVERSION variable that could be set by command-line to override the one set in the CMakeLists.txt file. Change-Id: Ic8137766ee3a0fb5b51cc49d2ea39d8d66e48b3f Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c54809b..682b42d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,8 @@ CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
include(GNUInstallDirs)
set(TARGET_NAME "afb-helpers")
+set(AGLVERSION 6.99 CACHE STRING "Current AGL Version")
+set(PROJECT_VERSION ${AGLVERSION} CACHE STRING "Project version can override AGLVERSION")
set(PROJECT_PRETTY_NAME "Afb Helpers")
set(PROJECT_DESCRIPTION "Library providing some helpful functions for apps using Application Framework Binder")
set(PROJECT_URL "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/libafb-helpers")