summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-08-22 11:15:42 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2018-12-13 14:58:22 +0100
commit2aea7b449c6cb58ef8c02146e47ebec418f8074d (patch)
treeec9869ba96328701ac8dd8291dd42687f9e5a453 /CMakeLists.txt
parent4e5ece0f4f95882e91f8974cd9b129e1630e862b (diff)
Controller binding extraction from Audio-bindings
Change-Id: I494bf5163c218a6d499b8321797f5de693c284c2 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 2 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7602f8..e62a0e8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,15 +16,6 @@
# limitations under the License.
###########################################################################
-ADD_COMPILE_OPTIONS(-DCONTROL_ONLOAD_PROFILE="onload-default-profile")
-
-ADD_COMPILE_OPTIONS(-DCONTROL_DOSCRIPT_PRE="doscript")
-ADD_COMPILE_OPTIONS(-DCONTROL_CONFIG_PRE="onload")
-ADD_COMPILE_OPTIONS(-DCONTROL_CONFIG_POST="control")
-ADD_COMPILE_OPTIONS(-DCONTROL_CONFIG_PATH="${CMAKE_SOURCE_DIR}/conf.d/project/config.d:${CMAKE_INSTALL_PREFIX}/controller/config.d")
-ADD_COMPILE_OPTIONS(-DCTL_PLUGIN_MAGIC=2468013579)
-ADD_COMPILE_OPTIONS(-DCONTROL_PLUGIN_PATH="${CMAKE_BINARY_DIR}:${CMAKE_INSTALL_PREFIX}/controller-plugins:/usr/lib/afb/controller-plugins/ctlplug")
-
# Include LUA only when requested
if(CONTROL_SUPPORT_LUA)
message(STATUS "Notice: LUA Controler Support Selected")
@@ -40,7 +31,7 @@ endif(CONTROL_SUPPORT_LUA)
PROJECT_TARGET_ADD(control-afb)
# Define project Targets
- ADD_LIBRARY(${TARGET_NAME} MODULE ctl-binding.c ctl-timer.c ctl-dispatch.c ${CTL_LUA_SOURCE})
+ ADD_LIBRARY(${TARGET_NAME} MODULE ctl-binding.c ctl-timer.c ctl-dispatch.c ${CTL_LUA_SOURCE} filescan-utils.c wrap-json.c)
SET_OPENAPI_FILENAME("ctl-apidef")
# Binder exposes a unique public entry point
@@ -53,14 +44,13 @@ PROJECT_TARGET_ADD(control-afb)
# Library dependencies (include updates automatically)
TARGET_LINK_LIBRARIES(${TARGET_NAME}
- audio-common
${link_libraries}
)
PROJECT_TARGET_ADD(audio-plugin-sample)
- # Define targets
+ # Define targets
ADD_LIBRARY(${TARGET_NAME} MODULE ctl-plugin-sample.c)
# Alsa Plugin properties
@@ -72,7 +62,6 @@ PROJECT_TARGET_ADD(audio-plugin-sample)
# Library dependencies (include updates automatically)
TARGET_LINK_LIBRARIES(${TARGET_NAME}
- audio-common
${link_libraries}
)