summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-08-16 18:50:57 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2018-12-13 14:57:57 +0100
commitc5a169452c50dcf53e27bbf3266d235e8d0eaecb (patch)
tree4878d75630f70e73ce3b4b918a96e45f3b467a33 /CMakeLists.txt
parent116bbad71e6ac661bd4783aac78848115fa754c4 (diff)
Integrate OpenAPI .h file generation.
Change-Id: I166d5019893308f239c3485ae03e87bf4a05cc5d Signed-off-by: Romain Forlot <romain.forlot@iot.bzh> # Conflicts: # Controler-afb/CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9e8e60..7ac0842 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,6 +43,7 @@ PROJECT_TARGET_ADD(control-afb)
# Generate API-v2 hat from OpenAPI json definition
SET_TARGET_GENSKEL(${TARGET_NAME} ctl-apidef)
+ SET_OPENAPI_FILENAME("afb-control-afb")
# Binder exposes a unique public entry point
SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
PREFIX "afb-"