summaryrefslogtreecommitdiffstats
path: root/ctl-lib/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-05-06 14:24:42 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2018-12-13 15:02:54 +0100
commit6fed20d35d556afa95537a2be0b0efc8a2dd24c7 (patch)
treeab073906b708cfb2fd7811de5e440e27515087da /ctl-lib/CMakeLists.txt
parentfc2e5bc18026460bddcfd84c74e880193079a5c9 (diff)
Upgrade config schema
Change the way to load LUA scripts. They are now considerate as Plugin and loads with them. This imply rework of how to search and find plugins as well as the way to load LUA. Also load an harcoded LUA scripts providing LUA helpers and managing global variables lock unlock mechanism Change-Id: I64e38aa27278d0cfdca787155db2d0c89953f905 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'ctl-lib/CMakeLists.txt')
-rw-r--r--ctl-lib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/ctl-lib/CMakeLists.txt b/ctl-lib/CMakeLists.txt
index 4f29014..3ab0774 100644
--- a/ctl-lib/CMakeLists.txt
+++ b/ctl-lib/CMakeLists.txt
@@ -19,7 +19,7 @@
# Include LUA only when requested
if(CONTROL_SUPPORT_LUA)
message(STATUS "Notice: LUA Controler Support Selected")
- set(CTL_LUA_SOURCE ctl-lua.c ctl-timer.c)
+ set(CTL_LUA_SOURCE ctl-lua.c ctl-timer.c ctl-lua-utils.c)
ADD_COMPILE_OPTIONS(-DCONTROL_SUPPORT_LUA)
else(CONTROL_SUPPORT_LUA)
message(STATUS "Warning: LUA Without Support ")