summaryrefslogtreecommitdiffstats
path: root/ctl-plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2017-08-29 18:59:53 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2018-12-13 15:02:25 +0100
commit2e7d03b3de4eb29f07cf7f467280e3a47fd1612b (patch)
tree71d5d81f0d559b8aac62a81d673678a893d71bea /ctl-plugin/CMakeLists.txt
parent52089a391c33a6dbde63c0b75ea1f8454fead723 (diff)
ctl-plugin: adjust deps; update app-templates
ctl-plugin must not be linked with ctl-binder. Otherwise, this produces some error like this depending on cmake version: ----- CMake Error at ctl-plugin/CMakeLists.txt:44 (TARGET_LINK_LIBRARIES): Target "afb-controller" of type MODULE_LIBRARY may not be linked into another target. One may link only to STATIC or SHARED libraries, or to executables with the ENABLE_EXPORTS property set. ----- Change-Id: I514b01e51da108c6a2ba09a96159779fe6e6797f Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'ctl-plugin/CMakeLists.txt')
-rw-r--r--ctl-plugin/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/ctl-plugin/CMakeLists.txt b/ctl-plugin/CMakeLists.txt
index fb2009f..d89e67d 100644
--- a/ctl-plugin/CMakeLists.txt
+++ b/ctl-plugin/CMakeLists.txt
@@ -43,7 +43,6 @@ PROJECT_TARGET_ADD(audio-plugin-sample)
# Library dependencies (include updates automatically)
TARGET_LINK_LIBRARIES(${TARGET_NAME}
afb-utilities
- afb-controller
${link_libraries}
)