summaryrefslogtreecommitdiffstats
path: root/htdocs/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-08-22 19:23:03 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2018-12-13 14:59:14 +0100
commit1abf8567328fc22b66f56782ea2061dae5a73d65 (patch)
tree19f157748aa186864e894d4820480cf90499d48f /htdocs/CMakeLists.txt
parentf2510aef47e63ba5d10f73057ebd194f7de3cf11 (diff)
Adding control panel sample HTML5 UI
Change-Id: Id7cb7e3f1a817000c9054139922bdf9e3e21a0a8 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'htdocs/CMakeLists.txt')
-rw-r--r--htdocs/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/htdocs/CMakeLists.txt b/htdocs/CMakeLists.txt
new file mode 100644
index 0000000..322033d
--- /dev/null
+++ b/htdocs/CMakeLists.txt
@@ -0,0 +1,34 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+
+##################################################
+# HTML Testing Files
+##################################################
+PROJECT_TARGET_ADD(htdocs)
+
+ file(GLOB SOURCE_FILES "*.html" "*.js" "*.jpg" "*.css")
+
+ add_input_files("${SOURCE_FILES}")
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "HTDOCS"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+