aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..9af162f
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,32 @@
+#*************************************************************************
+#
+# FIBERDYNE CONFIDENTIAL
+# __________________
+#
+# [2010] - [2017] Fiberdyne Systems Pty Ltd
+# All Rights Reserved.
+#
+# NOTICE: All information contained herein is, and remains
+# the property of Fiberdyne Systems Pty Ltd and its suppliers,
+# if any. The intellectual and technical concepts contained
+# herein are proprietary to Fiberdyne Systems Pty Ltd
+# and its suppliers and may be covered by U.S. and Foreign Patents,
+# patents in process, and are protected by trade secret or copyright law.
+# Dissemination of this information or reproduction of this material
+# is strictly forbidden unless prior written permission is obtained
+# from Fiberdyne Systems Pty Ltd.
+#
+#*************************************************************************
+
+#-------------------------------------------------------------------------------
+# LIBAVIRT CONFIGURATION LIBRARY
+#-------------------------------------------------------------------------------
+
+# Defines
+add_definitions(-D_GNU_SOURCE)
+
+# Target
+add_library(avirt STATIC src/avirt_*.c)
+
+# Target includes
+target_include_directories(avirt PUBLIC include)