aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9af162f..68e817a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,11 +22,9 @@
# LIBAVIRT CONFIGURATION LIBRARY
#-------------------------------------------------------------------------------
-# Defines
-add_definitions(-D_GNU_SOURCE)
-
# Target
-add_library(avirt STATIC src/avirt_*.c)
+file(GLOB SOURCE_FILES "src/avirt-*.c")
+add_library(avirt STATIC ${SOURCE_FILES})
# Target includes
target_include_directories(avirt PUBLIC include)