summaryrefslogtreecommitdiffstats
path: root/sample/simple-egl/CMakeLists.txt
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-10-23 14:38:56 +0900
committerzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-10-30 11:30:27 +0900
commit46f7c260dd5e79116e7c6571cacbda1b89495c9e (patch)
tree3b95e99529d3c32dc4d6f95324ac860fbc11e523 /sample/simple-egl/CMakeLists.txt
parent572023336d9573d3d5636d7e61a8dd3ed8878b0d (diff)
Move sample from agl-service-homescreen-2017
This sample is using libhomescren with homescreen sevice, So better move inside of libhomescreen. Related Commit: https://gerrit.automotivelinux.org/gerrit/#/c/11429/ [Patch Sets 2] Rebased to c0e6b4d9496eacabeffc4115fad7c1a288de60c8 [Patch Sets 3] Delete ivi-application-client-protocol.h and some trailing whitespace. [Patch Sets 4] Change temlate/README to README.md [Patch Sets 5] Rebased to 572023336d9573d3d5636d7e61a8dd3ed8878b0d [Patch Sets 6] Add LICENSE.APL-2.0 and LICENSE.MIT to sample. Modify config.xml license to APL 2.0 + MIT. BUG-AGL: SPEC-988 Change-Id: Id9a1a2401a9a0a42442ce84025213036a4fccd78 Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Diffstat (limited to 'sample/simple-egl/CMakeLists.txt')
-rw-r--r--sample/simple-egl/CMakeLists.txt69
1 files changed, 69 insertions, 0 deletions
diff --git a/sample/simple-egl/CMakeLists.txt b/sample/simple-egl/CMakeLists.txt
new file mode 100644
index 0000000..3f4a6e9
--- /dev/null
+++ b/sample/simple-egl/CMakeLists.txt
@@ -0,0 +1,69 @@
+#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+project(simple-egl C CXX)
+
+cmake_minimum_required(VERSION 3.0)
+
+set(PROJECT_NAME "simple-egl")
+set(PROJECT_VERSION "1.0")
+set(PROJECT_PRETTY_NAME "SE")
+set(PROJECT_DESCRIPTION "Sample application for homescreen and windowmanager")
+set(PROJECT_URL "")
+set(CMAKE_CXX_FLAGS "-Wall -fpermissive")
+
+#source directory
+aux_source_directory(src DIR_SRCS)
+
+#head file path
+include_directories(include)
+
+#set extern libraries
+SET(LIBRARIES
+ libwindowmanager.so
+ libEGL.so
+ libGLESv2.so
+ libm.so
+ libwayland-egl.so
+ libwayland-client.so
+ libjson-c.so
+ libhomescreen.so
+ librt.so
+ libpthread.so
+)
+
+#add executable file
+add_executable(simple-egl ${DIR_SRCS})
+
+#add link library
+TARGET_LINK_LIBRARIES(simple-egl ${LIBRARIES})
+
+add_custom_command(TARGET simple-egl POST_BUILD
+ COMMAND cp -rf ${CMAKE_CURRENT_SOURCE_DIR}/package ${PROJECT_BINARY_DIR}
+ COMMAND cp -rf ${PROJECT_BINARY_DIR}/simple-egl ${PROJECT_BINARY_DIR}/package/root/bin)
+
+add_custom_target(widget DEPENDS ${PROJECT_BINARY_DIR}/package/root
+ COMMAND wgtpkg-pack -f -o ${PROJECT_BINARY_DIR}/package/${PROJECT_NAME}.wgt ${PROJECT_BINARY_DIR}/package/root)
+
+add_custom_target(hvac DEPENDS ${PROJECT_BINARY_DIR}/package/root
+ COMMAND mkdir -p ${PROJECT_BINARY_DIR}/package/hvac/bin
+ COMMAND cp -rf ${PROJECT_BINARY_DIR}/simple-egl ${PROJECT_BINARY_DIR}/package/hvac/bin/hvac
+ COMMAND wgtpkg-pack -f -o ${PROJECT_BINARY_DIR}/package/hvac.wgt ${PROJECT_BINARY_DIR}/package/hvac)
+
+add_custom_target(navi DEPENDS ${PROJECT_BINARY_DIR}/package/root
+ COMMAND mkdir -p ${PROJECT_BINARY_DIR}/package/navi/bin
+ COMMAND cp -rf ${PROJECT_BINARY_DIR}/simple-egl ${PROJECT_BINARY_DIR}/package/navi/bin/navi
+ COMMAND wgtpkg-pack -f -o ${PROJECT_BINARY_DIR}/package/navi.wgt ${PROJECT_BINARY_DIR}/package/navi)