summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2018-03-30 13:15:29 -0700
committerMatt Ranostay <matt.ranostay@konsulko.com>2018-04-06 21:30:16 -0700
commit416b30f8e23e64daeb7d1a72a231863cfe9f9b53 (patch)
tree821ca6eb3abde26bf03d66cbba951f4de5ae8c4f /CMakeLists.txt
parent0223839486802f3944df6e20b73dc93fa4a03727 (diff)
libqtappfw: mediaplayer: initial agl-service-mediaplayer binding support
Add initial support interface between agl-service-mediaplayer and libqtappfw Bug-AGL: SPEC-1375 Change-Id: I740d8cddfd73198b7a3246cb46c941da9f3175d1 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9f91d1e..64d377b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,12 +14,15 @@ CONFIGURE_FILE("qtappfw.pc.in" "qtappfw.pc" @ONLY)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw.pc
DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
-add_library(qtappfw SHARED message.cpp messageengine.cpp telephony.cpp telephonymessage.cpp weather.cpp weathermessage.cpp)
+add_library(qtappfw SHARED message.cpp messageengine.cpp
+ mediaplayer.cpp mediaplayermessage.cpp
+ telephony.cpp telephonymessage.cpp
+ weather.cpp weathermessage.cpp)
target_link_libraries(qtappfw Qt5::WebSockets)
set_target_properties(qtappfw PROPERTIES
VERSION ${PROJECT_VERSION}
SOVERSION 1
- PUBLIC_HEADER "message.h;messageengine.h;telephony.h;telephonymessage.h;weather.h;weathermessage.h")
+ PUBLIC_HEADER "message.h;messageengine.h;mediaplayer.h;mediaplayermessage.h;telephony.h;telephonymessage.h;weather.h;weathermessage.h")
target_include_directories(qtappfw PRIVATE .)
install(TARGETS qtappfw
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}