summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-12-20 15:45:26 -0500
committerScott Murray <scott.murray@konsulko.com>2019-12-20 15:45:26 -0500
commitaa6b53c6a1f1a2e138a95f24795f767d6a15d31e (patch)
tree05f0a876d05869935f3312aa3b851458d5d7facb /CMakeLists.txt
parent100316af08e530eb0e56165344363d6ad2edf395 (diff)
Backport voice message support
Backported changes from master branch include: 72eb23f fix parsing for all events, overloading for specific needs 21bba7d fix parsing event payload in presence of '\n' chars, and include signal emit for voice status and cbl changes. 9f3896c voice: register for all vshl events on start up 0ff12f7 voice: remove vshl-capabilities dependencies 16c4429 voice: add status events to VshlCoreVoiceMessages. da09164 voice: add initial support for voice agents configuration Bug-AGL: SPEC-2981, SPEC-2880, SPEC-3060 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia75ff0c8d180324459fe8a2d8fb844b7b288d057
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index acee230..df37791 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -55,6 +55,7 @@ set (SUBDIRS
radio
signal-composer
telephony
+ voice
weather)
add_headers(message.h messageengine.h responsemessage.h)