summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2018-02-06 15:52:25 -0800
committerMatt Ranostay <matt.ranostay@konsulko.com>2018-02-09 20:17:51 -0800
commit0223839486802f3944df6e20b73dc93fa4a03727 (patch)
tree17d5be726c36a713aad297c90350596e413eebf0 /CMakeLists.txt
parent112fc8be473f02befc7596750ad7044113f29849 (diff)
Add weather binding support
Allow subscription of weather data for libqtappfw consumers Bug-AGL: SPEC-1273 Change-Id: If794481e09084f9632387c64882861faefe4f62c Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 122c193..9f91d1e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,12 +14,12 @@ CONFIGURE_FILE("qtappfw.pc.in" "qtappfw.pc" @ONLY)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw.pc
DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
-add_library(qtappfw SHARED message.cpp messageengine.cpp telephony.cpp telephonymessage.cpp)
+add_library(qtappfw SHARED message.cpp messageengine.cpp telephony.cpp telephonymessage.cpp weather.cpp weathermessage.cpp)
target_link_libraries(qtappfw Qt5::WebSockets)
set_target_properties(qtappfw PROPERTIES
VERSION ${PROJECT_VERSION}
SOVERSION 1
- PUBLIC_HEADER "message.h;messageengine.h;telephony.h;telephonymessage.h")
+ PUBLIC_HEADER "message.h;messageengine.h;telephony.h;telephonymessage.h;weather.h;weathermessage.h")
target_include_directories(qtappfw PRIVATE .)
install(TARGETS qtappfw
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}