summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Porter <mporter@konsulko.com>2017-11-08 08:57:32 -0500
committerMatt Porter <mporter@konsulko.com>2017-11-09 08:24:23 -0500
commit112fc8be473f02befc7596750ad7044113f29849 (patch)
tree5e70e7dc6c33a5cde68bad84165144ea9a86d7ab /CMakeLists.txt
parenta2fa6ce695f8532a8f974990b3b12dded18caa92 (diff)
Add base AGL libqtappfw and Telephony supporteel_4.99.3eel/4.99.34.99.3
Implements several QtObject subclasses that wrap functionality provided by the AGL Application Framework. * Message provides facilities to create new AppFW requests and parse AppFw replies/events from a JSON buffer. * MessageEngine provides a websocket message processing client that can send or receive Messages on a given websocket address. * TelephonyMessage subclasses Message to provide accessors and methods specific to the AGL Telephony API. * Telephony provides a complete set of Qt properties/signals/methods that expose the AGL Telephony functionality to Qt/QML applications. An application normally instantiates only this class and has no need to handle low-level AppFW messages. Bug-AGL: SPEC-1064 Change-Id: I2e41fb866bb4f867c81ccaf9bf33d627893879c8 Signed-off-by: Matt Porter <mporter@konsulko.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..122c193
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,26 @@
+cmake_minimum_required(VERSION 3.7.2)
+project(libqtappfw VERSION 1.0.0 LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+set(CMAKE_AUTOMOC ON)
+
+find_package(Qt5WebSockets REQUIRED)
+
+include(GNUInstallDirs)
+
+set(DEST_DIR "${CMAKE_INSTALL_PREFIX}")
+set(PRIVATE_LIBS "${PRIVATE_LIBS} -lqtappfw")
+CONFIGURE_FILE("qtappfw.pc.in" "qtappfw.pc" @ONLY)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw.pc
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
+
+add_library(qtappfw SHARED message.cpp messageengine.cpp telephony.cpp telephonymessage.cpp)
+target_link_libraries(qtappfw Qt5::WebSockets)
+set_target_properties(qtappfw PROPERTIES
+ VERSION ${PROJECT_VERSION}
+ SOVERSION 1
+ PUBLIC_HEADER "message.h;messageengine.h;telephony.h;telephonymessage.h")
+target_include_directories(qtappfw PRIVATE .)
+install(TARGETS qtappfw
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/qtappfw)