summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Porter <mporter@konsulko.com>2018-07-13 15:00:38 -0400
committerMatt Porter <mporter@konsulko.com>2018-07-25 19:20:05 -0400
commit1cc398602a32f2a5a816efe643ff2fe35b1cd42f (patch)
treee8e258f9187876e4da40c8024be36115252e7a96 /CMakeLists.txt
parent7427e664e232ed59bdffa37c63435a19febee778 (diff)
network: add wifinetworkmodel
Add WifiNetworkModel which exposes a QAbstractListModel of WiFi networks to QML. Bug-AGL: SPEC-1541 Change-Id: I1f4d41f1d1ceaa9b06a4b3df8b0b1cf41ea97ed2 Signed-off-by: Matt Porter <mporter@konsulko.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e67540a..811eae0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,7 @@ project(libqtappfw VERSION 1.0.0 LANGUAGES CXX)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
+find_package(Qt5Declarative REQUIRED)
find_package(Qt5WebSockets REQUIRED)
include(GNUInstallDirs)