summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Porter <mporter@konsulko.com>2018-06-19 14:56:26 -0400
committerMatt Porter <mporter@konsulko.com>2018-06-22 16:38:30 -0400
commite8b328e0516d8ead9af13c8379a6cd1dbbb8a9e9 (patch)
treedec002e6adcf197c3ac7913fb211b65b73772bc9 /CMakeLists.txt
parentfc65716b43af6be84d42599d813d3d40df07d376 (diff)
pbap: add contacts support and recent call model
Add support for parsing contacts and recent call data from the PBAP-provided vCards using libvcard. Expose a recent call list model and interfaces to refresh the data. Bug-AGL: SPEC-1436 Change-Id: Ia4a02443e22e4a27dc974ef414b765667b26ff83 Signed-off-by: Matt Porter <mporter@konsulko.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 249f3ac..9165f49 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,7 +21,7 @@ add_library(qtappfw SHARED message.cpp messageengine.cpp
pbap.cpp pbapmessage.cpp
telephony.cpp telephonymessage.cpp
weather.cpp weathermessage.cpp)
-target_link_libraries(qtappfw Qt5::WebSockets)
+target_link_libraries(qtappfw Qt5::WebSockets vcard)
set_target_properties(qtappfw PROPERTIES
VERSION ${PROJECT_VERSION}
SOVERSION 1