summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-06 20:40:19 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-04 21:21:37 +0000
commit607f2b680891c25b51917d5b7f20bc3a3ffc6a65 (patch)
tree3c0853006bac0dd1c1b6e382fcc60124decc2541 /CMakeLists.txt
parent1332cc7d0a618ee88b4d19813340665332d406ca (diff)
Add VIS vehicle signal support
Add vehicle-signals library that exposes configuration and interface objects to use Vehicle Information Service (VIS) signals from a VIS server such as KUKSA.val. In this initial version Qt signals to expose some of the low level VIS errors to clients have not been implemented, as it is not immediately obvious how they could be leveraged in the AGL demo usecases. If the Qt demos continue to be used for past the Needlefish release this may warrant revisiting. Bug-AGL: SPEC-4408 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I05d2bfdd09d090e3ed13ba4e4c2d1d205357d6e4 (cherry picked from commit b34fae267102d374bcc9ab7a6ff6a259515bb6bf)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a766d3f..a4def83 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,7 @@ set(CMAKE_AUTOMOC ON)
set(OE_QMAKE_PATH_EXTERNAL_HOST_BINS $ENV{OE_QMAKE_PATH_HOST_BINS})
find_package(Qt5Qml REQUIRED)
+find_package(Qt5WebSockets REQUIRED)
find_package(PkgConfig REQUIRED)
pkg_check_modules(glib REQUIRED IMPORTED_TARGET glib-2.0)
@@ -26,6 +27,7 @@ set(PRIVATE_LIBS "${PRIVATE_LIBS} -lqtappfw-bt
-lqtappfw-pbap
-lqtappfw-radio
-lqtappfw-telephony
+ -lqtappfw-vehicle-signals
-lqtappfw-weather")
set (SUBDIRS
@@ -39,6 +41,7 @@ set (SUBDIRS
pbap
radio
telephony
+ vehicle-signals
weather)
foreach(subdir ${SUBDIRS})