summaryrefslogtreecommitdiffstats
path: root/bluetooth/meson.build
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-19 13:19:46 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-19 13:19:56 +0100
commit4f75c049e8ba1e7fd4f1094f9ed8b681318f021d (patch)
treeaa98230ff962aeba9775c459515b229c8eac47a0 /bluetooth/meson.build
parent1d78b4a6f9ba4807901c6fc30ece2b84754908e8 (diff)
Import the patches for the demo applications into the app repos. Bug-AGL: SPEC-5294 Change-Id: I516a951cdd49dbfb1729bf4e49360333b951bad3 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'bluetooth/meson.build')
-rw-r--r--bluetooth/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/bluetooth/meson.build b/bluetooth/meson.build
index 008fda1..c8f7e0f 100644
--- a/bluetooth/meson.build
+++ b/bluetooth/meson.build
@@ -1,17 +1,17 @@
-qt5_dep = dependency('qt5', modules: ['Core', 'Qml'])
+qt_dep = dependency('qt6', modules: ['Core', 'Qml'])
glib_dep = [dependency('glib-2.0'), dependency('gio-2.0'), dependency('gobject-2.0'), dependency('gio-unix-2.0')]
bluez_glib_dep = dependency('bluez-glib')
-moc_files = qt5.compile_moc(headers : ['bluetooth.h', 'bluetoothmodel.h'],
- dependencies: qt5_dep)
+moc_files = qt.compile_moc(headers : ['bluetooth.h', 'bluetoothmodel.h'],
+ dependencies: qt_dep)
src = ['bluetooth.cpp', 'bluetoothmodel.cpp', 'bluetootheventhandler.cpp', moc_files]
lib = shared_library('qtappfw-bt',
sources: src,
version: '1.0.0',
soversion: '0',
- dependencies: [qt5_dep, glib_dep, bluez_glib_dep],
+ dependencies: [qt_dep, glib_dep, bluez_glib_dep],
install: true)
install_headers('bluetooth.h')
@@ -21,7 +21,7 @@ pkg_mod.generate(libraries : lib,
version : '1.0',
name : 'libqtappfw-bt',
filebase : 'qtappfw-bt',
- requires: 'Qt5Qml',
+ requires: 'Qt6Qml',
description : 'AGL Qt demo app framework helper library for using BlueZ.')
qtappfw_bt_dep = declare_dependency(link_with: lib,