summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorRaquel Medina <raquel.medina@konsulko.com>2020-06-01 00:54:11 +0200
committerRaquel Medina <raquel.medina@konsulko.com>2020-06-09 23:17:30 +0200
commitae208a6a303982535c44a7f124f38b4252528ab4 (patch)
tree91c75a9442c209c6360d8b539be2dd50832ff1b3 /core/CMakeLists.txt
parent45dc51ab0564fdec1595f1e193a18abfced88ec5 (diff)
split qtappfw in independent qtappfw-* modules
Bug-AGL: SPEC-3390 Signed-off-by: Raquel Medina <raquel.medina@konsulko.com> Change-Id: Ib8096c8dd2d59d3728e824ae13ba401da0971dc4
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
new file mode 100644
index 0000000..3102f3b
--- /dev/null
+++ b/core/CMakeLists.txt
@@ -0,0 +1,28 @@
+
+CONFIGURE_FILE("qtappfw-core.pc.in" "qtappfw-core.pc" @ONLY)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw-core.pc
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
+
+add_library(qtappfw-core SHARED message.cpp
+ messagefactory.cpp
+ messageengine.cpp
+ messageenginefactory.cpp
+ responsemessage.cpp
+ callmessage.cpp
+ eventmessage.cpp)
+
+target_include_directories(qtappfw-core PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
+target_include_directories(qtappfw-core PUBLIC "${CMAKE_INSTALL_INCLUDEDIR}")
+
+target_link_libraries(qtappfw-core Qt5::WebSockets)
+
+set_target_properties(qtappfw-core PROPERTIES
+ VERSION ${PROJECT_VERSION}
+ SOVERSION 1
+ PUBLIC_HEADER "message.h;messagefactory.h;messageengine.h;messageenginefactory.h;responsemessage.h;callmessage.h;eventmessage.h")
+
+
+install(TARGETS qtappfw-core
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/qtappfw-core)
+