summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-09-19 17:46:22 -0400
committerScott Murray <scott.murray@konsulko.com>2022-09-21 14:34:54 +0000
commit06810868c74ddea6e336fd8f44692a975c628eba (patch)
treefc9c197e85136a4e9315ddec1889c5033aad5bbe /meson.build
parent6420728323808d6eea8f83688631f149af186e5d (diff)
Add meson.build files
Add meson configuration missed in previous commit. Bug-AGL: SPEC-4559 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Idbcd961ab91cf48e7dc3b841aee3a79d0b615dcd (cherry picked from commit 5bf2b9d30ccea0f5468b22abedbe1629691eab15)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build50
1 files changed, 50 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..df905f6
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2022 Konsulko Group
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+project (
+ 'libqtappfw',
+ ['cpp'],
+ version : '1.0.0',
+ license : 'Apache-2.0',
+ meson_version : '>= 0.46.0',
+ default_options :
+ [
+ 'warning_level=1',
+ 'buildtype=debugoptimized',
+ 'c_std=c17',
+ 'cpp_std=c++17'
+ ],
+)
+
+qt5 = import('qt5')
+
+#subdir('docs')
+
+# These need to be first as they declare dependencies for use in some
+# of the other libraries
+subdir('bluetooth')
+subdir('vehicle-signals')
+
+subdir('applauncher')
+subdir('hvac')
+subdir('map')
+subdir('mediaplayer')
+subdir('navigation')
+subdir('network')
+subdir('pbap')
+subdir('radio')
+subdir('telephony')
+subdir('weather')