summaryrefslogtreecommitdiffstats
path: root/navigation/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-07 14:40:57 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-04 21:23:16 +0000
commitfc9399e54dfd05a4307f954549ae58afbf57fb5e (patch)
tree22ea8bb39aac75e56bcf8ee2c44b8e9f354b07d2 /navigation/CMakeLists.txt
parent607f2b680891c25b51917d5b7f20bc3a3ffc6a65 (diff)
Reimplement navigation API with VIS signals
Reimplement the navigation interface with use of VIS signals. There is some impedance mismatching done between VIS signal notifications and the API Qt signals to avoid changing the clients signficantly for now. If the Qt demo lifetime is extended, this may be revisited to either switch to directly using the VehicleSignals interface or doing a more granular mapping that works better with the VSS schema / VIS. Bug-AGL: SPEC-4408 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ieab42daddadca60de634f414171a133af53938f5 (cherry picked from commit 4ce04ff30e753556cf9cb371780f2a873f6fedaa)
Diffstat (limited to 'navigation/CMakeLists.txt')
-rw-r--r--navigation/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/navigation/CMakeLists.txt b/navigation/CMakeLists.txt
index 6264623..9e0ee84 100644
--- a/navigation/CMakeLists.txt
+++ b/navigation/CMakeLists.txt
@@ -8,7 +8,7 @@ add_library(qtappfw-navigation SHARED navigation.cpp)
target_include_directories(qtappfw-navigation PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
target_include_directories(qtappfw-navigation PUBLIC "${CMAKE_INSTALL_INCLUDEDIR}")
-target_link_libraries(qtappfw-navigation Qt5::Qml)
+target_link_libraries(qtappfw-navigation Qt5::Qml qtappfw-vehicle-signals)
set_target_properties(qtappfw-navigation PROPERTIES
VERSION ${PROJECT_VERSION}
SOVERSION 1