summaryrefslogtreecommitdiffstats
path: root/telephony/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-02-14 18:04:15 -0500
committerScott Murray <scott.murray@konsulko.com>2022-02-15 17:15:16 -0500
commit0de8ac83e6a190d5fc124587d1f9f0a7f0198ce3 (patch)
tree8e5f07cdc014e493ec42a9b506104a35752101e0 /telephony/CMakeLists.txt
parent3f384d30d099f6eea5eb946c3cb0380f0453e2bc (diff)
Re-enable telephony and radio stub libraries
Add the radio, telephony, pbap, and map libraries back to the build by stubbing out their implementations for now. This should enable getting the related apps building without the application framework and hopefully simplify further rework of the backend functionality here with respect to AGL CI. Bug-AGL: SPEC-4182 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I9c7cae9f34a9fd332a11914bcb6ee123b840d5a1
Diffstat (limited to 'telephony/CMakeLists.txt')
-rw-r--r--telephony/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/telephony/CMakeLists.txt b/telephony/CMakeLists.txt
index 7c4e5b5..5bd81bc 100644
--- a/telephony/CMakeLists.txt
+++ b/telephony/CMakeLists.txt
@@ -8,7 +8,7 @@ add_library(qtappfw-phone SHARED telephony.cpp)
target_include_directories(qtappfw-phone PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
target_include_directories(qtappfw-phone PUBLIC "${CMAKE_INSTALL_INCLUDEDIR}")
-target_link_libraries(qtappfw-phone qtappfw-core)
+target_link_libraries(qtappfw-phone Qt5::Qml)
set_target_properties(qtappfw-phone PROPERTIES
VERSION ${PROJECT_VERSION}
SOVERSION 1