summaryrefslogtreecommitdiffstats
path: root/vehicle-signals/meson.build
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-19 13:19:46 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-19 13:19:56 +0100
commit4f75c049e8ba1e7fd4f1094f9ed8b681318f021d (patch)
treeaa98230ff962aeba9775c459515b229c8eac47a0 /vehicle-signals/meson.build
parent1d78b4a6f9ba4807901c6fc30ece2b84754908e8 (diff)
Import the patches for the demo applications into the app repos. Bug-AGL: SPEC-5294 Change-Id: I516a951cdd49dbfb1729bf4e49360333b951bad3 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'vehicle-signals/meson.build')
-rw-r--r--vehicle-signals/meson.build14
1 files changed, 7 insertions, 7 deletions
diff --git a/vehicle-signals/meson.build b/vehicle-signals/meson.build
index 50383e4..4dd766c 100644
--- a/vehicle-signals/meson.build
+++ b/vehicle-signals/meson.build
@@ -1,10 +1,10 @@
cpp = meson.get_compiler('cpp')
grpcpp_reflection_dep = cpp.find_library('grpc++_reflection')
-qt5_dep = dependency('qt5', modules: ['Core', 'Concurrent'])
+qt_dep = dependency('qt6', modules: ['Core', 'Concurrent'])
vs_dep = [
- qt5_dep,
+ qt_dep,
dependency('protobuf'),
dependency('grpc'),
dependency('grpc++'),
@@ -30,14 +30,14 @@ grpc_gen = generator(protoc, \
output : ['@BASENAME@.grpc.pb.cc', '@BASENAME@.grpc.pb.h'],
arguments : ['-I=' + protos_base_dir,
'--grpc_out=@BUILD_DIR@',
- '--plugin=protoc-gen-grpc=' + grpc_cpp.path(),
+ '--plugin=protoc-gen-grpc=' + grpc_cpp.full_path(),
'@INPUT@'])
generated_grpc_sources = [ \
grpc_gen.process(protos_dir / 'val.proto', preserve_path_from : protos_base_dir),
]
-moc_files = qt5.compile_moc(headers: [ 'vehiclesignals.h', 'QtKuksaClient.h' ],
- dependencies: qt5_dep)
+moc_files = qt.compile_moc(headers: [ 'vehiclesignals.h', 'QtKuksaClient.h' ],
+ dependencies: qt_dep)
src = [
'vehiclesignals.cpp',
@@ -62,10 +62,10 @@ pkg_mod.generate(libraries: lib,
version: '1.0',
name: 'libqtappfw-vehicle-signals',
filebase: 'qtappfw-vehicle-signals',
- requires: ['Qt5Core'],
+ requires: ['Qt6Core'],
description: 'Library wrapping VSS API in Qt objects')
-qtappfw_vs_dep = declare_dependency(dependencies: qt5_dep,
+qtappfw_vs_dep = declare_dependency(dependencies: qt_dep,
link_with: lib,
include_directories: '.',
sources: ['vehiclesignals.h'])