summaryrefslogtreecommitdiffstats
path: root/mediaplayer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mediaplayer/CMakeLists.txt')
-rw-r--r--mediaplayer/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/mediaplayer/CMakeLists.txt b/mediaplayer/CMakeLists.txt
index e21b590..3f77b8d 100644
--- a/mediaplayer/CMakeLists.txt
+++ b/mediaplayer/CMakeLists.txt
@@ -3,12 +3,15 @@ CONFIGURE_FILE("qtappfw-mediaplayer.pc.in" "qtappfw-mediaplayer.pc" @ONLY)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw-mediaplayer.pc
DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
-add_library(qtappfw-mediaplayer SHARED mediaplayer.cpp)
+add_library(qtappfw-mediaplayer SHARED
+ mediaplayer.cpp
+ MediaplayerMpdBackend.cpp
+ MpdEventHandler.cpp)
target_include_directories(qtappfw-mediaplayer PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
target_include_directories(qtappfw-mediaplayer PUBLIC "${CMAKE_INSTALL_INCLUDEDIR}")
-target_link_libraries(qtappfw-mediaplayer qtappfw-core)
+target_link_libraries(qtappfw-mediaplayer Qt5::Qml PkgConfig::libmpdclient)
set_target_properties(qtappfw-mediaplayer PROPERTIES
VERSION ${PROJECT_VERSION}
SOVERSION 1