summaryrefslogtreecommitdiffstats
path: root/mediaplayer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mediaplayer/CMakeLists.txt')
-rw-r--r--mediaplayer/CMakeLists.txt24
1 files changed, 0 insertions, 24 deletions
diff --git a/mediaplayer/CMakeLists.txt b/mediaplayer/CMakeLists.txt
deleted file mode 100644
index 35dda69..0000000
--- a/mediaplayer/CMakeLists.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-
-CONFIGURE_FILE("qtappfw-mediaplayer.pc.in" "qtappfw-mediaplayer.pc" @ONLY)
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw-mediaplayer.pc
- DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
-
-add_library(qtappfw-mediaplayer SHARED
- mediaplayer.cpp
- MediaplayerBackend.cpp
- MediaplayerMpdBackend.cpp
- MediaplayerBluezBackend.cpp
- MpdEventHandler.cpp)
-
-target_include_directories(qtappfw-mediaplayer PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
-target_include_directories(qtappfw-mediaplayer PUBLIC "${CMAKE_INSTALL_INCLUDEDIR}")
-
-target_link_libraries(qtappfw-mediaplayer qtappfw-bt Qt5::Qml PkgConfig::libmpdclient)
-set_target_properties(qtappfw-mediaplayer PROPERTIES
- VERSION ${PROJECT_VERSION}
- SOVERSION 1
- PUBLIC_HEADER mediaplayer.h)
-
-install(TARGETS qtappfw-mediaplayer
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/qtappfw-mediaplayer)