summaryrefslogtreecommitdiffstats
path: root/pbap/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pbap/CMakeLists.txt')
-rw-r--r--pbap/CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/pbap/CMakeLists.txt b/pbap/CMakeLists.txt
deleted file mode 100644
index 480661a..0000000
--- a/pbap/CMakeLists.txt
+++ /dev/null
@@ -1,19 +0,0 @@
-
-CONFIGURE_FILE("qtappfw-bt-pbap.pc.in" "qtappfw-bt-pbap.pc" @ONLY)
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw-bt-pbap.pc
- DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
-
-add_library(qtappfw-bt-pbap SHARED pbap.cpp)
-
-target_include_directories(qtappfw-bt-pbap PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
-target_include_directories(qtappfw-bt-pbap PUBLIC "${CMAKE_INSTALL_INCLUDEDIR}")
-
-target_link_libraries(qtappfw-bt-pbap Qt5::Qml)
-set_target_properties(qtappfw-bt-pbap PROPERTIES
- VERSION ${PROJECT_VERSION}
- SOVERSION 1
- PUBLIC_HEADER pbap.h)
-
-install(TARGETS qtappfw-bt-pbap
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/qtappfw-bt-pbap)