summaryrefslogtreecommitdiffstats
path: root/radio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'radio/CMakeLists.txt')
-rw-r--r--radio/CMakeLists.txt21
1 files changed, 19 insertions, 2 deletions
diff --git a/radio/CMakeLists.txt b/radio/CMakeLists.txt
index a6b8db4..8cce350 100644
--- a/radio/CMakeLists.txt
+++ b/radio/CMakeLists.txt
@@ -1,2 +1,19 @@
-add_headers(radio.h)
-add_sources(radio.cpp)
+
+CONFIGURE_FILE("qtappfw-radio.pc.in" "qtappfw-radio.pc" @ONLY)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw-radio.pc
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
+
+add_library(qtappfw-radio SHARED radio.cpp)
+
+target_include_directories(qtappfw-radio PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
+target_include_directories(qtappfw-radio PUBLIC "${CMAKE_INSTALL_INCLUDEDIR}")
+
+target_link_libraries(qtappfw-radio qtappfw-core)
+set_target_properties(qtappfw-radio PROPERTIES
+ VERSION ${PROJECT_VERSION}
+ SOVERSION 1
+ PUBLIC_HEADER radio.h)
+
+install(TARGETS qtappfw-radio
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/qtappfw-radio)