summaryrefslogtreecommitdiffstats
path: root/voice/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'voice/CMakeLists.txt')
-rw-r--r--voice/CMakeLists.txt26
1 files changed, 22 insertions, 4 deletions
diff --git a/voice/CMakeLists.txt b/voice/CMakeLists.txt
index 6363c3b..3de0586 100644
--- a/voice/CMakeLists.txt
+++ b/voice/CMakeLists.txt
@@ -1,4 +1,22 @@
-add_headers(voice.h
- voiceagentregistry.h voiceagentprofile.h voiceagentmodel.h)
-add_sources(voice.cpp
- voiceagentregistry.cpp voiceagentprofile.cpp voiceagentmodel.cpp)
+
+CONFIGURE_FILE("qtappfw-voice.pc.in" "qtappfw-voice.pc" @ONLY)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw-voice.pc
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
+
+add_library(qtappfw-voice SHARED voice.cpp
+ voiceagentregistry.cpp
+ voiceagentprofile.cpp
+ voiceagentmodel.cpp)
+
+target_include_directories(qtappfw-voice PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
+target_include_directories(qtappfw-voice PUBLIC "${CMAKE_INSTALL_INCLUDEDIR}")
+
+target_link_libraries(qtappfw-voice qtappfw-core)
+set_target_properties(qtappfw-voice PROPERTIES
+ VERSION ${PROJECT_VERSION}
+ SOVERSION 1
+ PUBLIC_HEADER "voice.h;voiceagentregistry.h;voiceagentprofile.h;voiceagentmodel.h")
+
+install(TARGETS qtappfw-voice
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/qtappfw-voice)