aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2022-07-21 06:02:36 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2022-08-02 01:01:32 +0900
commit6bf3f5a870a28c7989a24ab6ae3040c650f84897 (patch)
treee4b3aeffaa96f9238e207d12c66071cfe9b50acf /configure.ac
parenta34f8913fbe3fc82ed32754ec6976d1a6f7904e6 (diff)
Rename library and header filename to librefop
Previously this library name is libredundancyfileop, but it's too long for use. This patch rename library for libredundancyfileop to librefop. Bug-AGL: SPEC-4500 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: I450c31cfe36f246489f9198e4cf2cfd6e85cb0ab
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 2 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index f95ddd0..c30e796 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,11 +1,9 @@
AC_PREREQ([2.69])
-AC_INIT([exsample], [1.0])
+AC_INIT([librefop], [1.0])
AM_INIT_AUTOMAKE([foreign subdir-objects])
-#AC_CONFIG_SRCDIR([src/exsample.cpp])
-
AC_CONFIG_HEADERS([include/config.h])
AC_CONFIG_MACRO_DIR([m4])
@@ -29,13 +27,6 @@ AC_ARG_ENABLE([test],
[enable_test=no])
AM_CONDITIONAL([ENABLE_TEST], [test "$enable_test" = "yes"])
-
-AC_ARG_ENABLE([printfdebug],
- [AS_HELP_STRING([--enable-printfdebug], [Enable user printf debug (default is no)])],
- [:],
- [enable_printfdebug=no])
-AM_CONDITIONAL([ENABLE_PRINTFDEBUG], [test "$enable_printfdebug" = "yes"])
-
# Checks for programs.
AC_PROG_CC
AC_PROG_CXX
@@ -60,7 +51,7 @@ PKG_CHECK_MODULES([GMOCK_MAIN], [gmock_main], , enable_test=no)
AC_CONFIG_FILES([
Makefile
- libredundancyfileop.pc
+ librefop.pc
lib/Makefile
test/Makefile
])