summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2022-07-20 08:13:43 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2022-08-02 01:01:32 +0900
commita34f8913fbe3fc82ed32754ec6976d1a6f7904e6 (patch)
tree6ab53895bc2d62f983dff89ad2ba189b52ffc5b5 /test/Makefile.am
parent0ca708eae20ba675458c29124f771c8f29dd12a7 (diff)
Update test case for file operations
This patch add test case for file operations into source tree. Bug-AGL: SPEC-4500 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: I37c3fb3f2c0260a844cb6d6ea984cc6c868cee1b
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 050390e..d48109a 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -4,6 +4,8 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
bin_PROGRAMS = \
interface_test interface_test_unit \
fileop_test_utils \
+ fileop_test_set_get_remove \
+ fileop_test_unit \
file_util_test
interface_test_SOURCES = \
@@ -23,6 +25,16 @@ fileop_test_utils_SOURCES = \
../lib/static-configurator.c \
../lib/file-util.c
+fileop_test_set_get_remove_SOURCES = \
+ fileop_test_set_get_remove.cpp \
+ ../lib/static-configurator.c \
+ ../lib/file-util.c
+
+
+fileop_test_unit_SOURCES = \
+ fileop_test_unit.cpp \
+ ../lib/static-configurator.c
+
file_util_test_SOURCES = \
file_util_test.cpp
@@ -39,6 +51,7 @@ interface_test_LDADD = \
# C compiler options
CFLAGS = \
-g \
+ -fpermissive \
-fsanitize=address -coverage \
-I$(top_srcdir)/lib \
-I$(top_srcdir)/include \
@@ -47,6 +60,7 @@ CFLAGS = \
# C++ compiler options
CXXFLAGS = \
-g \
+ -fpermissive \
-std=c++11 -fno-exceptions \
-fsanitize=address -coverage \
-I$(top_srcdir)/lib \