summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt40
1 files changed, 0 insertions, 40 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
deleted file mode 100644
index 8c9b2ce..0000000
--- a/CMakeLists.txt
+++ /dev/null
@@ -1,40 +0,0 @@
-#
-# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-project(libsoundmanager CXX)
-
-cmake_minimum_required(VERSION 2.8)
-
-set(PROJECT_NAME "Soundmanager client library")
-set(PROJECT_VERSION "1.0")
-set(PROJECT_PRETTY_NAME "libsm")
-set(PROJECT_INCLUDEDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR})
-set(PROJECT_LIBDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
-
-# get pkgconfig
-INCLUDE(FindPkgConfig)
-link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
-
-set(CMAKE_BUILD_TYPE Debug)
-add_definitions(-DDEBUGMODE)
-
-add_subdirectory(src)
-
-#generate configure file
-configure_file(libsoundmanager.pc.in libsoundmanager.pc @ONLY)
-INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/libsoundmanager.pc
- DESTINATION
- ${CMAKE_INSTALL_LIBDIR}/pkgconfig)