summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt50
1 files changed, 0 insertions, 50 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
deleted file mode 100644
index 1a34347..0000000
--- a/src/CMakeLists.txt
+++ /dev/null
@@ -1,50 +0,0 @@
-#
-# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-
-cmake_minimum_required(VERSION 2.8)
-
-set(TARGET_LIBSM soundmanager)
-add_definitions("-std=c++11")
-
-pkg_check_modules(libsm_depends json-c libafbwsc libsystemd)
-set(libsm_sources libsoundmanager.cpp)
-
-link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
-
-add_library(${TARGET_LIBSM} SHARED ${libsm_sources})
-target_compile_options(${TARGET_LIBSM} PUBLIC ${libsm_depends_CFLAGS})
-
-if(DEFINED DEBUGMODE)
- target_compile_options(${TARGET_LIBSM} PRIVATE -g -O0)
-else(DEFINED DEBUGMODE)
- target_compile_options(${TARGET_LIBSM} PRIVATE -g -O2)
-endif(DEFINED DEBUGMODE)
-
-include_directories(${TARGET_LIBSM} ${libsm_depends_INCLUDE_DIRS})
-target_link_libraries(${TARGET_LIBSM} afbwsc ${link_libraries} ${libsm_depends_LIBRARIES})
-
-if(DEFINED CMAKE_INSTALL_LIBDIR)
- INSTALL(TARGETS ${TARGET_LIBSM}
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
-endif(DEFINED CMAKE_INSTALL_LIBDIR)
-if(DEFINED CMAKE_INSTALL_INCLUDEDIR)
- INSTALL(FILES libsoundmanager.hpp DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
-endif(DEFINED CMAKE_INSTALL_INCLUDEDIR)
-
-#####################
-#add_subdirectory(test)
-