aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-06-13 17:20:05 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-06-13 17:20:05 +0200
commit014ba2dd29eaadb4d61948ca417c25112f76ee0e (patch)
tree85a9e9540ebcea63053a817993290eac45076962 /CMakeLists.txt
parent21ffc6687e175d5cfb73500e45e61195d061ec72 (diff)
Import CAN generator from low-level-can-service
Also use the app-templates CMake helpers. Change-Id: I034e5efa9baa0f686a081f60df5c3588e4b3bd51 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..4eadb8b
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,29 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/config.cmake)
+include(${PROJECT_APP_TEMPLATES_DIR}/cmake/common.cmake)
+
+# Bindings to compile
+# --------------------
+project_subdirs_add()
+
+project_closing_msg()