summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2019-11-26 16:07:15 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2019-11-26 16:07:15 +0100
commit0d65a0be7d834b23de99e73bba5407185f54aeca (patch)
treed97480eb71cf39a13d7c89a297ff5a3b9aaa5bfb /src/CMakeLists.txt
parent839bbf458685383634c03e8cec2238f70c6f0382 (diff)
This commit allows to generate a file according to the version. And adds the wrapper function for new decoder between v1 and v2. Bug-AGL: SPEC-2780 Bug-AGL: SPEC-2976 Change-Id: I169d5a8213d6a14e5d77b600e14b36f0878b3efe Signed-off-by: Arthur Guyader <arthur.guyader@iot.bzh> Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2824b71..5da7e6e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -28,7 +28,9 @@ add_executable(${TARGET_NAME}
openxc/command.cpp
openxc/diagnostic_message.cpp
openxc/mapping.cpp
- openxc/signal.cpp)
+ openxc/signal.cpp
+ openxc/decoder.cpp
+ )
TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/../3rdparty/json