aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-06-13 17:20:05 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-06-13 17:20:05 +0200
commit014ba2dd29eaadb4d61948ca417c25112f76ee0e (patch)
tree85a9e9540ebcea63053a817993290eac45076962 /src/CMakeLists.txt
parent21ffc6687e175d5cfb73500e45e61195d061ec72 (diff)
Import CAN generator from low-level-can-service
Also use the app-templates CMake helpers. Change-Id: I034e5efa9baa0f686a081f60df5c3588e4b3bd51 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..263185f
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,44 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(can-config-generator)
+
+ # Define project Targets
+ add_executable(${TARGET_NAME}
+ main.cpp
+ openxc/message_set.cpp
+ openxc/can_bus.cpp
+ openxc/can_message.cpp
+ openxc/command.cpp
+ openxc/diagnostic_message.cpp
+ openxc/mapping.cpp
+ openxc/signal.cpp)
+
+ TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/../3rdparty/json
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(can-config-generator
+ ${link_libraries}
+ )
+
+ # installation directory
+ INSTALL(TARGETS can-config-generator
+RUNTIME DESTINATION ${BINDINGS_INSTALL_DIR})