aboutsummaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
authorJulian Bouzas <julian.bouzas@collabora.com>2021-04-20 04:08:58 -0400
committerGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2021-07-28 13:19:02 +0300
commitf25bb13718f334bc0c96d29ea9f3a57c0a6f3a34 (patch)
treeeaa30eafe2df92e3d5d75571d022c3a775246bff /tests/meson.build
parent7bf96bda703dd157385cbb175ec90bd6f38af404 (diff)
lib: add wpipc library
Simple library that uses sockets for inter-process communication. It provides an API to create server and client objects. Users can add custom handlers in the server, and clients can send requests for those custom handlers. Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..12771c0
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,26 @@
+common_deps = [icipc_dep, glib_dep]
+common_env = [
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir()),
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+]
+
+test(
+ 'test-icipc-sender-receiver',
+ executable('test-sender-receiver', 'sender-receiver.c', dependencies: common_deps),
+ env: common_env,
+ workdir : meson.current_source_dir(),
+)
+
+test(
+ 'test-icipc-protocol',
+ executable('test-protocol', 'protocol.c', dependencies: common_deps),
+ env: common_env,
+ workdir : meson.current_source_dir(),
+)
+
+test(
+ 'test-icipc-client-server',
+ executable('test-client-server', 'client-server.c', dependencies: common_deps),
+ env: common_env,
+ workdir : meson.current_source_dir(),
+)