aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build40
1 files changed, 40 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..c342c42
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,40 @@
+project('icipc', ['c'],
+ version : '0.1',
+ license : 'MIT',
+ meson_version : '>= 0.52.0',
+ default_options : [
+ 'warning_level=1',
+ 'buildtype=debugoptimized',
+ ]
+)
+
+threads_dep = dependency('threads', required: true)
+spa_dep = dependency('libspa-0.2', version: '>= 0.2', required: true)
+glib_dep = dependency('glib-2.0', required: true)
+
+pkgconfig = import('pkgconfig')
+cc = meson.get_compiler('c')
+
+common_flags = [
+ '-fvisibility=hidden',
+ '-Wsuggest-attribute=format',
+ '-Wsign-compare',
+ '-Wpointer-arith',
+ '-Wpointer-sign',
+ '-Wformat',
+ '-Wformat-security',
+ '-Wimplicit-fallthrough',
+ '-Wmissing-braces',
+ '-Wtype-limits',
+ '-Wvariadic-macros',
+ '-Wno-missing-field-initializers',
+ '-Wno-unused-parameter',
+ '-Wno-pedantic',
+ '-Wold-style-declaration',
+ '-Wunused-result',
+]
+add_project_arguments(cc.get_supported_arguments(common_flags), language: 'c')
+
+subdir('lib')
+subdir('src')
+subdir('tests')