aboutsummaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..12771c0
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,26 @@
+common_deps = [icipc_dep, glib_dep]
+common_env = [
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir()),
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+]
+
+test(
+ 'test-icipc-sender-receiver',
+ executable('test-sender-receiver', 'sender-receiver.c', dependencies: common_deps),
+ env: common_env,
+ workdir : meson.current_source_dir(),
+)
+
+test(
+ 'test-icipc-protocol',
+ executable('test-protocol', 'protocol.c', dependencies: common_deps),
+ env: common_env,
+ workdir : meson.current_source_dir(),
+)
+
+test(
+ 'test-icipc-client-server',
+ executable('test-client-server', 'client-server.c', dependencies: common_deps),
+ env: common_env,
+ workdir : meson.current_source_dir(),
+)