summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorEdi Feschiyan <edi.feschiyan@konsulko.com>2020-07-13 18:17:03 +0300
committerEdi Feschiyan <edi.feschiyan@konsulko.com>2020-07-13 18:17:03 +0300
commitf2b375ab71f654888c19a8fdfe777507a7f7095f (patch)
tree88cf3305f155b0f25d96f0eaac6518ecdc119605 /setup.py
parente5d2e4f5ab62165c42435f155a190a42c5e73e0d (diff)
when pytests are run on Python 3.8 the test gathering and execution order is reversed and may break tests which require state to be carried over
adding pytest-reverse to requirements/setup.py to be readily available if needed
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 07e764d..68e8f3d 100644
--- a/setup.py
+++ b/setup.py
@@ -14,7 +14,7 @@ setuptools.setup(
url="https://github.com/refresher/pyagl",
packages=setuptools.find_packages(),
license="Apache 2.0",
- install_requires=['websockets', 'parse', 'asyncssh', 'pytest', 'pytest-asyncio', 'pytest-dependency'],
+ install_requires=['websockets', 'parse', 'asyncssh', 'pytest', 'pytest-asyncio', 'pytest-dependency', 'pytest-reverse'],
classifiers=[
'Development Status :: 4 - Beta',
'Environment :: Console',