diff options
author | Edi Feschiyan <553226+refresher@users.noreply.github.com> | 2020-06-18 13:12:31 +0300 |
---|---|---|
committer | Edi Feschiyan <553226+refresher@users.noreply.github.com> | 2020-06-18 13:12:31 +0300 |
commit | 80159d8789fe2ea0b36d84b83348813f67e18652 (patch) | |
tree | a997c5013257bdb7d02518d86c21595c15a33ced /setup.py | |
parent | 8a8b87e65c0b3d579f8ea420e23a9cd07528dfe1 (diff) |
Rearranging files for distribution, setup.py modifications
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 26 |
1 files changed, 26 insertions, 0 deletions
@@ -0,0 +1,26 @@ +import setuptools + +with open("README.md", "r") as fh: + long_description = fh.read() + +setuptools.setup( + name="pyagl", + version="0.0.1", + author="Edi Feschiyan", + author_email="edi.feschiyan@konsulko.com", + description="Python bindings and tests for Automotive Grade Linux services", + long_description=long_description, + long_description_content_type="text/markdown", + url="https://github.com/refresher/pyagl", + packages=setuptools.find_packages(), + license="Apache 2.0", + install_requires=['websockets', 'parse', 'asyncssh', 'pytest', 'pytest-asyncio'], + classifiers=[ + 'Development Status :: 4 - Beta', + 'Environment :: Console', + "Programming Language :: Python :: 3", + "License :: OSI Approved :: Apache Software License", + "Operating System :: POSIX :: Linux", + ], + python_requires='>=3.6', +) |