aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/vhost-user-gpu/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/vhost-user-gpu/meson.build')
-rw-r--r--contrib/vhost-user-gpu/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/contrib/vhost-user-gpu/meson.build b/contrib/vhost-user-gpu/meson.build
new file mode 100644
index 000000000..92c8f3a86
--- /dev/null
+++ b/contrib/vhost-user-gpu/meson.build
@@ -0,0 +1,12 @@
+if 'CONFIG_TOOLS' in config_host and virgl.found() and gbm.found() \
+ and 'CONFIG_LINUX' in config_host and pixman.found()
+ executable('vhost-user-gpu', files('vhost-user-gpu.c', 'virgl.c', 'vugbm.c'),
+ dependencies: [qemuutil, pixman, gbm, virgl, vhost_user, opengl],
+ install: true,
+ install_dir: get_option('libexecdir'))
+
+ configure_file(input: '50-qemu-gpu.json.in',
+ output: '50-qemu-gpu.json',
+ configuration: { 'libexecdir' : get_option('prefix') / get_option('libexecdir') },
+ install_dir: qemu_datadir / 'vhost-user')
+endif