aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/csharp/2 library/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/csharp/2 library/meson.build')
-rw-r--r--meson/test cases/csharp/2 library/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/meson/test cases/csharp/2 library/meson.build b/meson/test cases/csharp/2 library/meson.build
new file mode 100644
index 000000000..6b246a4bd
--- /dev/null
+++ b/meson/test cases/csharp/2 library/meson.build
@@ -0,0 +1,15 @@
+project('C# library', 'cs')
+
+python3 = import('python3').find_python()
+generated_sources = custom_target('gen_sources',
+ input: 'helper.cs',
+ output: 'helper.cs',
+ command: [python3, '-c',
+ 'import shutil, sys; shutil.copyfile(sys.argv[1], sys.argv[2])',
+ '@INPUT@', '@OUTPUT@']
+)
+
+l = shared_library('helper', generated_sources, install : true)
+
+e = executable('prog', 'prog.cs', link_with : l, install : true)
+test('libtest', e)