aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/osx/4 framework/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/osx/4 framework/meson.build')
-rw-r--r--meson/test cases/osx/4 framework/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/meson/test cases/osx/4 framework/meson.build b/meson/test cases/osx/4 framework/meson.build
new file mode 100644
index 000000000..460b48074
--- /dev/null
+++ b/meson/test cases/osx/4 framework/meson.build
@@ -0,0 +1,23 @@
+# Primitive test for adding frameworks in XCode
+# When opening the xcodeproj, the Folder "Frameworks" should contain two frameworks (OpenGL.framework and Foundation.framework)
+# "Target Membership" of ...
+# - OpenGL.framework should be only to prog@exe
+# - Foundation.framework should be only to stat@sta
+# "Build Phase" / "Link Binary with Libraries" for the target
+# - "prog@exe" should be only "Foundation.framework"
+# - "stat@sta" should be only "OpenGL.framework"
+# see "xcode-frameworks.png" for an example
+
+project('xcode framework test', 'c', default_options : ['libdir=libtest'])
+
+dep_libs = dependency('appleframeworks', modules : ['OpenGL'], required : false)
+if not dep_libs.found()
+ error('OpenGL framework not found')
+endif
+assert(dep_libs.type_name() == 'appleframeworks', 'type_name is wrong')
+
+dep_main = dependency('appleframeworks', modules : ['Foundation'])
+
+stlib = static_library('stat', 'stat.c', install : true, dependencies: dep_libs)
+exe = executable('prog', 'prog.c', install : true, dependencies: dep_main)
+