aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/unit/39 python extmodule/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/unit/39 python extmodule/meson.build')
-rw-r--r--meson/test cases/unit/39 python extmodule/meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/meson/test cases/unit/39 python extmodule/meson.build b/meson/test cases/unit/39 python extmodule/meson.build
new file mode 100644
index 000000000..5b443944b
--- /dev/null
+++ b/meson/test cases/unit/39 python extmodule/meson.build
@@ -0,0 +1,26 @@
+project('Python extension module', 'c',
+ default_options : ['buildtype=release'])
+
+py_mod = import('python')
+
+py = py_mod.find_installation(get_option('python'), required : false)
+
+if py.found()
+ py_dep = py.dependency(required : false)
+
+ if py_dep.found()
+ subdir('ext')
+
+ test('extmod',
+ py,
+ args : files('blaster.py'),
+ env : ['PYTHONPATH=' + pypathdir])
+ else
+ error('MESON_SKIP_TEST: Python libraries not found, skipping test.')
+ endif
+else
+ error('MESON_SKIP_TEST: Python not found, skipping test.')
+endif
+
+py = py_mod.find_installation(get_option('python'), required : get_option('disabled_opt'))
+assert(not py.found(), 'find_installation not working with disabled feature')