summaryrefslogtreecommitdiffstats
path: root/waltham-transmitter/transmitter-plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorWataru Mizuno <wmizuno@jp.adit-jv.com>2018-07-09 18:14:05 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-07-27 10:51:25 +0000
commit18aa25385bcfc4c686f4700de2b2dd9fa9b38ee9 (patch)
tree80f21089c49102054e4dde84f008564793d0e07d /waltham-transmitter/transmitter-plugin/CMakeLists.txt
parent067686a3a5865511c5c59738c6324b29c87d9d3a (diff)
transmitter: initial commit for waltham-transmitter
The waltham-transmitter is the plugin of weston to enable client applications to share surface between multiple domains. Change-Id: I691410f5b6e74fa981ae53201b728810373185a2 Signed-off-by: Wataru Mizuno <wmizuno@jp.adit-jv.com>
Diffstat (limited to 'waltham-transmitter/transmitter-plugin/CMakeLists.txt')
-rw-r--r--waltham-transmitter/transmitter-plugin/CMakeLists.txt62
1 files changed, 62 insertions, 0 deletions
diff --git a/waltham-transmitter/transmitter-plugin/CMakeLists.txt b/waltham-transmitter/transmitter-plugin/CMakeLists.txt
new file mode 100644
index 0000000..a900d3b
--- /dev/null
+++ b/waltham-transmitter/transmitter-plugin/CMakeLists.txt
@@ -0,0 +1,62 @@
+project (transmitter)
+
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(WAYLAND_SERVER wayland-server>=1.13.0 REQUIRED)
+pkg_check_modules(WESTON weston>=2.0.0 REQUIRED)
+pkg_check_modules(PIXMAN pixman-1 REQUIRED)
+pkg_check_modules(WALTHAM waltham REQUIRED)
+
+include_directories(
+ include
+ ${CMAKE_SOURCE_DIR}/waltham-transmitter/waltham-renderer
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${WAYLAND_CLIENT_INCLUDE_DIRS}
+ ${WAYLAND_SERVER_INCLUDE_DIRS}
+ ${WESTON_INCLUDE_DIRS}
+ ${PIXMAN_INCLUDE_DIRS}
+ ${WALTHAM_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${WAYLAND_SERVER_LIBRARY_DIRS}
+ ${WESTON_LIBRARY_DIRS}
+ ${PIXMAN_LIBRARY_DIRS}
+ ${WALTHAM_LIBRARY_DIRS}
+)
+
+add_library(${PROJECT_NAME} MODULE
+ plugin.c
+ output.c
+ input.c
+ plugin.h
+ transmitter_api.h
+)
+
+set_target_properties(${PROJECT_NAME} PROPERTIES PREFIX "")
+
+set(LIBS
+ m
+ ${WAYLAND_SERVER_LIBRARIES}
+ ${WESTON_LIBRARIES}
+ ${PIXMAN_LIBRARIES}
+ ${WALTHAM_LIBRARIES}
+)
+
+SET(SRC_FILES
+ plugin.c
+ output.c
+ input.c
+ plugin.h
+ transmitter_api.h
+)
+
+
+
+add_dependencies(${PROJECT_NAME} ${LIBS})
+
+target_link_libraries(${PROJECT_NAME} ${LIBS})
+
+install (
+ TARGETS ${PROJECT_NAME}
+ LIBRARY DESTINATION lib64/weston
+)