summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2023-03-03 12:13:24 +0200
committerMarius Vlad <marius.vlad@collabora.com>2023-03-08 13:34:11 +0200
commit8b057267c4180e5648b6636f4b5b1de07f627977 (patch)
tree9dd68e6a5e5a4142c6658d00fe180eb8e4ec7673 /meson.build
parentdf7c14cabeb91f3e98395b6a7b461b408eb91d81 (diff)
window-management-rpc: Client for testing out grpc proxy
This test client for trying/testing out the RPC API with the compositor. It implements floating and fullscreen functionality. Further patches would include split and remoting. Bug-AGL: SPEC-4673 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I960eac1f60c359629343efef03f4fab586d7c3af
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build30
1 files changed, 30 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..beb933d
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,30 @@
+#
+# Copyright 2023 Collabora, Ltd.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+project (
+ 'c', 'cpp',
+ version: '0.0.1',
+ default_options: [
+ 'warning_level=3',
+ 'c_std=c2x',
+ 'cpp_std=c++20'
+ ],
+ meson_version: '>= 0.60',
+ license: 'MIT/Expat',
+)
+
+qt5 = import('qt5')
+subdir('src')