aboutsummaryrefslogtreecommitdiffstats
path: root/conf.d/packaging/rpm/agl-xds-cli.spec
diff options
context:
space:
mode:
Diffstat (limited to 'conf.d/packaging/rpm/agl-xds-cli.spec')
-rw-r--r--conf.d/packaging/rpm/agl-xds-cli.spec12
1 files changed, 9 insertions, 3 deletions
diff --git a/conf.d/packaging/rpm/agl-xds-cli.spec b/conf.d/packaging/rpm/agl-xds-cli.spec
index f3f00db..ad3cc7b 100644
--- a/conf.d/packaging/rpm/agl-xds-cli.spec
+++ b/conf.d/packaging/rpm/agl-xds-cli.spec
@@ -6,14 +6,15 @@
%global debug_package %{nil}
Name: agl-xds-cli
-Version: 1.1.1
+Version: 0.0.0
Release: 0
License: Apache-2.0
Summary: Command line tool to interact with XDS
-Url: https://github.com/iotbzh/xds-cli.git
-Source0: xds-cli_linux-amd64-v%{version}_2018-04-05_110646.zip
+Url: https://gerrit.automotivelinux.org/gerrit/p/src/xds/xds-cli.git
+Source0: xds-cli_linux-amd64-%{version}.zip
BuildRequires: unzip
BuildRoot: %{_tmppath}/%{name}-%{version}-build
+Group: Development/Tools/Debuggers
%description
xds-cli is a client tool that should be used to interact with an XDS server.
@@ -27,6 +28,10 @@ xds-cli is a client tool that should be used to interact with an XDS server.
mkdir -p %{?buildroot}%{_prefix}/xds/cli %{?buildroot}%{_bindir}
cp xds-cli %{?buildroot}%{_prefix}/xds/cli
ln -s ../xds/cli/xds-cli %{?buildroot}%{_bindir}/xds-cli
+
+mkdir -p %{?buildroot}%{_sysconfdir}/bash_completion.d
+cp ./conf.d/etc/bash_completion.d/xds-cli %{?buildroot}%{_sysconfdir}/bash_completion.d/
+
mkdir -p %{?buildroot}%{_sysconfdir}/profile.d
sed -e "s;@XDS_INSTALL_BIN_DIR@;%{_bindir};g" ./conf.d/etc/profile.d/xds-cli.sh > %{buildroot}%{_sysconfdir}/profile.d/%{name}.sh
@@ -38,5 +43,6 @@ sed -e "s;@XDS_INSTALL_BIN_DIR@;%{_bindir};g" ./conf.d/etc/profile.d/xds-cli.sh
%dir %{_prefix}/xds/cli
%{_prefix}/xds/cli/*
%{_bindir}/xds-cli
+%attr(644,root,root) %{_sysconfdir}/bash_completion.d/xds-cli
%config %{_sysconfdir}/profile.d/%{name}.sh
%attr(644,root,root) %{_sysconfdir}/profile.d/%{name}.sh